Sharing is helping.

We offer you this space to share your knowledge about Magento and learn from our experienced customers.

    Home Forums Theme Forum HelloMinty Tables in Product Description

    This topic contains 4 replies, has 3 voices, and was last updated by  Anonymous 5 years, 3 months ago.

    Viewing 5 posts - 1 through 5 (of 5 total)
    • Author
    • #12669


      Wonder if you can help,

      I have just wrote a simple table in HTML code to display some prices and for some reason the table is jumping to the bottom of the page and not sitting under the title and it does not matter what I do with the code it seems to add a massive gap – the original code is:


      <h4>A4 (210mm x 297mm):</h4>
      <table border=”0″ cellspacing=”0″>
      <th bgcolor=”#FF0066″ height=”50″></th>
      <th bgcolor=”#FF0066″ align=”center” width=”100″><font color=”white”>100</font></th>
      <th bgcolor=”#FF0066″ align=”center” width=”100″><font color=”white”>200</font></th>
      <th bgcolor=”#FF0066″ align=”center” width=”100″><font color=”white”>500</font></th>
      <th bgcolor=”#FF0066″ align=”center” width=”100″><font color=”white”>1,000</font></th>
      <th bgcolor=”#FF0066″ align=”center” width=”100″><font color=”white”>2,500</font></th>
      <th bgcolor=”#FF0066″ align=”center” width=”100″><font color=”white”>5,000</font></th>
      <th bgcolor=”#FF0066″ align=”center” width=”100″><font color=”white”>10,000</font></th>
      <td width=”100″>Single-Sided</td>
      <td align=”center”>£<b>39</b></td>
      <td align=”center”>£<b>67</b></td>
      <td align=”center”>£<b>85</b></td>
      <td align=”center”>£<b>124</b></td>
      <td align=”center”>£<b>157</b></td>
      <td align=”center”>£<b>212</b></td>
      <td align=”center”>£<b>322</b></td>
      <td width=”100″ bgcolor=”#FDF5E6″>Double-Sided</td>
      <td align=”center” bgcolor=”#FDF5E6″>£<b>61</b></td>
      <td align=”center” bgcolor=”#FDF5E6″>£<b>117</b></td>
      <td align=”center” bgcolor=”#FDF5E6″>£<b>129</b></td>
      <td align=”center” bgcolor=”#FDF5E6″>£<b>144</b></td>
      <td align=”center” bgcolor=”#FDF5E6″>£<b>186</b></td>
      <td align=”center” bgcolor=”#FDF5E6″>£<b>257</b></td>
      <td align=”center” bgcolor=”#FDF5E6″>£<b>399</b></td>
      The WYSIWYG editor has changed it to this:

      <p>130Gsm Leaflet</p>
      <p> </p>
      <p>Select Quantityx 100: £39</p>
      <p>A4 (210mm x 297mm):</p>
      <table border=”0″ cellspacing=”0″>
      <tr style=”background-color: #ff1493;” align=”center”>
      <th style=”width: 60px; height: 60px;” align=”center”> </th> <th style=”width: 60px; height: 60px;” align=”center”><span style=”color: white;”>100</span></th> <th style=”width: 60px; height: 60px;” align=”center”><span style=”color: white;”>200</span></th> <th style=”width: 60px; height: 60px;” align=”center”><span style=”color: white;”>500</span></th> <th style=”width: 60px; height: 60px;” align=”center”><span style=”color: white;”>1,000</span></th> <th style=”width: 60px; height: 60px;” align=”center”><span style=”color: white;”>2,500</span></th> <th style=”width: 60px; height: 60px;” align=”center”><span style=”color: white;”>5,000</span></th> <th style=”width: 60px; height: 60px;” align=”center”><span style=”color: white;”>10,000</span></th>
      <td width=”100″>Single-Sided</td>
      <td align=”center”>£39</td>
      <td align=”center”>£67</td>
      <td align=”center”>£85</td>
      <td align=”center”>£124</td>
      <td align=”center”>£157</td>
      <td align=”center”>£212</td>
      <td align=”center”>£322</td>
      <td width=”100″ bgcolor=”#FDF5E6″>Double-Sided</td>
      <td align=”center” bgcolor=”#FDF5E6″>£61</td>
      <td align=”center” bgcolor=”#FDF5E6″>£117</td>
      <td align=”center” bgcolor=”#FDF5E6″>£129</td>
      <td align=”center” bgcolor=”#FDF5E6″>£144</td>
      <td align=”center” bgcolor=”#FDF5E6″>£186</td>
      <td align=”center” bgcolor=”#FDF5E6″>£257</td>
      <td align=”center” bgcolor=”#FDF5E6″>£399</td>
      Ends up like this on the site:

      I can’t see anything obvious and wonder if there is anything you might know that is causing this?



      Hi Andy, thanks for reporting this. To fix it, go to: appdesignfrontenddefaulthellomintytemplatecatalogproductviewdescription.phtml

      You will see this line:

      Remove this: nl2br

      The line should look like this then:

      Let us know if this helps you.

      Kind regards.-



      That worked, thanks!



      Great! :D




      Was looking for this same issue but for HelloPress.

      Works splendidly.

    Viewing 5 posts - 1 through 5 (of 5 total)
    Reply To: Tables in Product Description
    Your information:

    <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code class="" title="" data-url=""> <del datetime=""> <em> <i> <q cite=""> <strike> <strong> <pre class="" title="" data-url=""> <span class="" title="" data-url="">