Sharing is helping.

We offer you this space to share your knowledge about Magento and learn from our experienced customers.

    Home Forums Theme Forum HelloCurl & HelloCurl iPhone Short description used in catalog "list" view

    This topic contains 8 replies, has 3 voices, and was last updated by  Anonymous 6 years, 1 month ago.

    Viewing 9 posts - 1 through 9 (of 9 total)
    • Author
    • #16130



      For this theme, “short description” easily become the main description of an item as its what the users see first. With a few images, it can easily be 10-15 lines long.

      The problem is, that when viewing a catalog in “list” mode, the theme also includes the “short description” for each item. If its long, it looks crazy.

      Its no problem on your demo site: as you have VERY short “short description” that ends suddenly, e.g. for this model:

      “The words “entry level” no longer mean “low-end,” especially when it comes to the Nokia 2610. Offering advanced media and calling features without breaking the bank”

      Imagine if that description was 10 lines, what would this page look like in “list” mode:

      In what file do I modify that? E.g. only to show the first 5 lines.. or show a completely other text? Not sure if it theme specific or Magento setting?

      Thanks in advance.



      Hi, i understand how this could be an inconvenient for long “short descriptions”, but that’s the purpose of the long descriptions and the “Learn more” link.

      To edit how many lines you want to display, you should edit list.phtml (appdesignfrontenddefaulthellocurltemplatecatalogproductlist.phtml)



      Hi. Thanks. I sorted it in the code.

      Last question from me for now.. where do I change the character set used in your template?



      Actually the special characters are supported in all normal text, but its ONLY in the theme specific buttons they are not showing. As I can see its in

      - the “Add to cart” button on all pages.
      - the “Shopping cart” button on cart page.



      No solution to this?

      Some character set must not be set OK. I have checked translation, and the word is OK there. Also what is even more wierd, is that if I look in the code on a loaded page, its even OK there.. its just not “displayed” in browsers.

      Maybe its some css used to create the text, that only supports english characters?



      No answer?



      Hi Martin,

      I looked at your site. First off, I recommend you edit the .footer class and remove the width property so your site will fit on small screens.

      Ok, so this sounds like it could be a cufon issue. This script turns font characters into pictures to look nive and pretty. I’ve only spent enough time on cufon to know I don’t want to use it. I’ve removed it from my site JS. To get the font you want to use, you’ll have to download it and convert it to a file type cufon can read. Sorry I couldn’t be of more help.




      Hi Kevin,

      Thanks for the advice with the width, hadnt seen it myself.

      I tried disabling all cufon, and yes – it solved it. Though I see cufon is used for many things on my site, so cant fully disable it.

      So does you or anyone have an idea how I make it not affect the specific (e.g. h1) tags? I havent been able to locate where this is set, do you know that?



      Ah. I managed to sort it by changing the affected tag (h3) on all pages where there was problems.

    Viewing 9 posts - 1 through 9 (of 9 total)
    Reply To: Short description used in catalog "list" view
    Your information:

    <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code class="" title="" data-url=""> <del datetime=""> <em> <i> <q cite=""> <strike> <strong> <pre class="" title="" data-url=""> <span class="" title="" data-url="">