Sharing is helping.

We offer you this space to share your knowledge about Magento and learn from our experienced customers.


    Home Forums Theme Forum HelloKids & HelloKids iPhone Homepage not calling products!

    This topic contains 10 replies, has 3 voices, and was last updated by  Anonymous 5 years, 2 months ago.

    Viewing 11 posts - 1 through 11 (of 11 total)
    • Author
      Posts
    • #15571

      Anonymous

      Hello!

      I have a problem that I’ve been trying to solve for over 8 hours!! :roll:

      When I insert the:
      {{block type=”catalog/product_list” category_id=”22″ template=”catalog/product/list_homepage.phtml”}}

      in the homepage it opens ONLY IF THE CATEGORY DOESN’T EXIST, so it shows no products..

      HOWEVER, if I put a category ID that really represents a real category with real products, the page only loads the header, the logo, the search bar, the left navigation ONLY: NO CONTENT/BODY and NO FOOTER!!

      http://bebasata.com/media//with%20wrong%20category%20number.png

      http://bebasata.com/media//with%20correct%20category%20number.png

      Please help me out here! tell me what could have gone wrong?!

      #15572

      Anonymous

      Hi Mostafa,

      I am not from hello themes, but we use this code in the same place:

      <p>{{block type=”catalog/product_list” category_id=”31″ template=”catalog/product/list.phtml”}}</p>

      Note the template is different from yours, ours is working so try that.

      #15573

      Anonymous

      Thank you Christian!

      But it still doesn’t work! it seems that I have a problem with the files (PHP, phtml…etc) I have no idea what went wrong!!!

      #15574

      Anonymous

      Hi there, don’t get mad! :wink: , helloKids works correctly, there is surely some setting you are not adding right.

      Be sure of: Homepage, layout must be “Homepage” in the homepage configurations in your Admin panel.

      This is all the code for the helloKids homepage:

      In the category_id=”18″ field, you have to add the ID of the category with products that you want to display. Be sure to not change the default configurations in the category configuration section in your Admin panel.

      Let us know.
      Regards.-

      And that’s it,

      #15575

      Anonymous

      THANK YOU FOR YOUR REPLY :D

      however, the problem is bigger than my technical skills :(

      The issue is, the only block that is working is the ‘new products’ one, and it doesn’t work correctly, it displays the products in one column vertically !!

      If I try list.phtml or list_homepage.phtml it gives me a blank page (only the header & the left appear) with NO footer nor body/content!

      I really don’t know what’s going on and I am already late on launching!! I can’t believe this is actually happening to me!

      Please advise me what to do!

      #15576

      Anonymous

      Hello!, ok, make sure of this 3 things:
      1) Use this content in your Homepage configuration in your Admin-panel:

      2) Under your Homepage configuration page, in Design>Layout select “Homepage” option.

      3) In the same page, under Custom Design options, don’t modify anything there, all options must remain as –Please Select–

      Also, refresh or disable your cache during theme installation.
      Let us know if this helps you.

      Cheers!.-

      #15577

      Anonymous

      Hello!

      Well, I did that exactly as described:

      Here is what happens when I call: {{block type=”catalog/product_list” category_id=”18″ template=”catalog/product/list.phtml”}}

      http://bebasata.com/home-2
      _____________

      And when I call the featured_products.html :{{block type=”catalog/product_list” category_id=”18″ template=”catalog/product/featured_products.phtml”}}

      http://bebasata.com/home-3

      ______________

      could it be a permissions problem? java? mis-allocation of files?
      I am really thinking about opening a new cpanel, setting up new magento and start over!! :(

      #15578

      Anonymous

      Hi, i think that the modifications you did caused that. Please set up again the theme in a clean Magento install, test the theme without making changes, and if you are going to modify it, do it carefully, checking the theme after each modification you do.

      Kind regards.-

      #15579

      Anonymous

      Hi!

      I’ve been working on for like a week and finally I did it :D

      I have no idea what the problem was, but it was definitely in the database!
      so I created a new database (since I don’t know how to fix one)

      Downloaded a fresh new magento (1.5 this time), and a fresh new hellokids

      and started all the customization from scratch :D but I have to say, there is incredible development between hellokids 1.4 & 1.5 (well done :D )

      I just want to know, if there is a possibility to make the main categories in the left nav in bold? or bigger in font? cuz when u expand the subcategories, everything looks the same so u can’t find the main categories easily.. i know it should be done in the styles.css or in the leftnav.phtml but I won’t do anything till u guys tell me what’s right to do (i dont want to mess it up again :( )

      Thank you very much for the support!! you guys rock!! :D

      #15580

      Anonymous

      Hi there, thanks for the feedback!. You can edit the parent categories title from:
      appdesignfrontenddefaulthellokidstemplatecatalognavigationleftnav.phtml

      Find this line, about line 11:

      Add this:

      style=”font-weight:bold; font-size:15px;

      The line should look like this:

      You can change the values to your choice of course (font-size:15px) or add other properties.

      Cheers!!.-

      #15581

      Anonymous

      Thank you very much!! thats much better :D

    Viewing 11 posts - 1 through 11 (of 11 total)
    Reply To: Homepage not calling products!
    Your information:





    <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code class="" title="" data-url=""> <del datetime=""> <em> <i> <q cite=""> <strike> <strong> <pre class="" title="" data-url=""> <span class="" title="" data-url="">