Sharing is helping.

We offer you this space to share your knowledge about Magento and learn from our experienced customers.


    Home Forums Theme Forum HelloMinty Homepage Layout Not Available

    This topic contains 10 replies, has 5 voices, and was last updated by  Anonymous 6 years, 8 months ago.

    Viewing 11 posts - 1 through 11 (of 11 total)
    • Author
      Posts
    • #7302

      Anonymous

      I just did a fresh install of Magento ver. 1.4.0.1, and uploaded the HelloMinty theme files to my server. Everything seems to work fine, however, while configuring the CMS Static Blocks and the “Home” Page, I noticed that the “Homepage” layout template was not available in the dropdown menus. Only the default “Empty, 1 column, 2 columns, etc.” are visible.

      Any ideas?

      #7303

      Hello Themes
      Key Master

      @Brian Wendt

      Have you tried refreshing your cache? Go to System > Cache Management. Select all and in Actions select “Refresh” from the drop down menu.

      Then go back to your CMS > Pages. Select Home page and see if “Homepage” shows up on the drop down menu in Layout option.

      Let us know.

      #7304

      Anonymous

      I set the whole cache to disabled while making changes, and even then I still refresh it when things aren’t going as planned. I don’t think that was the problem, although Magento does some weird things when it comes to updating itself after code or layout changes.

      I basically ended up installing a clean copy of the theme, overwriting my changed copy, and that did the trick. Now I’m reapplying the changes one by one. I’m still not sure what happened.

      #7305

      Hello Themes
      Key Master

      @Brian Wendt

      Strange.. let us know if everything worked out okay.

      Thanks.

      #7306

      Anonymous

      I’ve got the same problem – no homepage layout.

      I’ve put all the files up again using ftp but still no luck…

      #7307

      Anonymous

      Hello – any hint on where to look? Am completely new to Magento but suspect there is an xml file either missing or having content missing somewhere – I need to get this sorted asap.

      #7308

      Anonymous

      @Nathan Sanders

      Try doing what Brian did, a fresh install. Did you install it with HelloUpload?

      #7309

      Anonymous

      HelloUpload doesn’t work – complains of missing files (which aren’t in the zip file), was told on email by yourselves to do it manually as you are having problems with HelloUpload.

      Error was:

      Can’t move folders. Please try again!
      exception ‘Exception’ with message ‘Warning: dir(/var/www/vhosts/<domainname>/httpdocs/media/helloupload/hellowear/theme/app/code/local/Mage/)

      Have already reuploaded all the files over FTP – same problem.

      #7310

      Anonymous

      Did you check the permissions of the folders?, make sure they are writable, that they have full permissions (777)

      #7311

      Anonymous

      Yes, done that. chmod -f -R 777 *

      Error is:

      Can’t move folders. Please try again!
      exception ‘Exception’ with message ‘Warning: dir(/var/www/vhosts/<domainname>/httpdocs/media/helloupload/hellowear/theme/app/code/local/Mage/) [function.dir]: failed to open dir: No such file or directory in /var/www/vhosts/<domainname>/httpdocs/app/code/local/Mage/Helloupload/controllers/Adminhtml/HellouploadController.php on line 44′ in /var/www/vhosts/<domainname>/httpdocs/app/code/core/Mage/Core/functions.php:245 Stack trace: #0 [internal function]: mageCoreErrorHandler(2, ‘dir(/var/www/vh…’, ‘/var/www/vhosts…’, 44, Array) #1 /var/www/vhosts/<domainname>/httpdocs/app/code/local/Mage/Helloupload/controllers/Adminhtml/HellouploadController.php(44): dir(‘/var/www/vhosts…’) #2 /var/www/vhosts/<domainname>/httpdocs/app/code/local/Mage/Helloupload/controllers/Adminhtml/HellouploadController.php(115): Mage_Helloupload_Adminhtml_HellouploadController->copyd(‘/var/www/vhosts…’, ‘/var/www/vhosts…’) #3 /var/www/vhosts/<domainname>/httpdocs/app/code/core/Mage/Core/Controller/Varien/Action.php(418): Mage_Helloupload_Adminhtml_HellouploadController->saveAction() #4 /var/www/vhosts/<domainname>/httpdocs/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(254): Mage_Core_Controller_Varien_Action->dispatch(‘save’) #5 /var/www/vhosts/<domainname>/httpdocs/app/code/core/Mage/Core/Controller/Varien/Front.php(177): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http)) #6 /var/www/vhosts/<domainname>/httpdocs/app/code/core/Mage/Core/Model/App.php(304): Mage_Core_Controller_Varien_Front->dispatch() #7 /var/www/vhosts/<domainname>/httpdocs/app/Mage.php(596): Mage_Core_Model_App->run(Array) #8 /var/www/vhosts/<domainname>/httpdocs/index.php(78): Mage::run(”, ‘store’) #9 {main}

      #7312

      Anonymous

      I have the same problem. I’m getting “Can’t move folders. Please try again!” using Hello Upload to install the Hello Minty theme.

      I am using Hello Upload version 0.1.1, and I have also set all folder permissions to 777.

      Any fix for this issue?

      Full Error Text:
      ——————————————
      Can’t move folders. Please try again!
      exception ‘Exception’ with message ‘Warning: mkdir(): Permission denied in /usr/local/pem/vhosts/123467/webspace/httpdocs/magento/app/code/local/Mage/Helloupload/controllers/Adminhtml/HellouploadController.php on line 41′ in /usr/local/pem/vhosts/123467/webspace/httpdocs/magento/app/code/core/Mage/Core/functions.php:245 Stack trace: #0 [internal function]: mageCoreErrorHandler(2, ‘mkdir(): Permis…’, ‘/usr/local/pem/…’, 41, Array) #1 /usr/local/pem/vhosts/123467/webspace/httpdocs/magento/app/code/local/Mage/Helloupload/controllers/Adminhtml/HellouploadController.php(41): mkdir(‘/usr/local/pem/…’) #2 /usr/local/pem/vhosts/123467/webspace/httpdocs/magento/app/code/local/Mage/Helloupload/controllers/Adminhtml/HellouploadController.php(52): Mage_Helloupload_Adminhtml_HellouploadController->copyd(‘/usr/local/pem/…’, ‘/usr/local/pem/…’) #3 /usr/local/pem/vhosts/123467/webspace/httpdocs/magento/app/code/local/Mage/Helloupload/controllers/Adminhtml/HellouploadController.php(115): Mage_Helloupload_Adminhtml_HellouploadController->copyd(‘/usr/local/pem/…’, ‘/usr/local/pem/…’) #4 /usr/local/pem/vhosts/123467/webspace/httpdocs/magento/app/code/core/Mage/Core/Controller/Varien/Action.php(418): Mage_Helloupload_Adminhtml_HellouploadController->saveAction() #5 /usr/local/pem/vhosts/123467/webspace/httpdocs/magento/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(254): Mage_Core_Controller_Varien_Action->dispatch(‘save’) #6 /usr/local/pem/vhosts/123467/webspace/httpdocs/magento/app/code/core/Mage/Core/Controller/Varien/Front.php(177): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http)) #7 /usr/local/pem/vhosts/123467/webspace/httpdocs/magento/app/code/core/Mage/Core/Model/App.php(304): Mage_Core_Controller_Varien_Front->dispatch() #8 /usr/local/pem/vhosts/123467/webspace/httpdocs/magento/app/Mage.php(596): Mage_Core_Model_App->run(Array) #9 /usr/local/pem/vhosts/123467/webspace/httpdocs/magento/index.php(78): Mage::run(”, ‘store’) #10 {main}

    Viewing 11 posts - 1 through 11 (of 11 total)
    Reply To: Homepage Layout Not Available
    Your information:





    <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code class="" title="" data-url=""> <del datetime=""> <em> <i> <q cite=""> <strike> <strong> <pre class="" title="" data-url=""> <span class="" title="" data-url="">