Sharing is helping.

We offer you this space to share your knowledge about Magento and learn from our experienced customers.


    Home Forums Reply To: Pager in Hellominty missing on search results pages Reply To: Pager in Hellominty missing on search results pages

    #12433

    Anonymous

    Hi

    I’m sorry to say that it doesn’t work. I get a long error message:

    Warning: simplexml_load_string() [function.simplexml-load-string]: Entity: line 72: parser error : Opening and ending tag mismatch: reference line 50 and block in /home/books/public_html/app/code/core/Mage/Core/Model/Layout/Update.php on line 431

    Trace:
    #0 /home/books/public_html/app/code/core/Mage/Core/Model/Layout/Update.php(431): mageCoreErrorHandler(2, ‘simplexml_load_…’, ‘/home/books/pub…’, 431, Array)
    #1 /home/books/public_html/app/code/core/Mage/Core/Model/Layout/Update.php(273): Mage_Core_Model_Layout_Update->getFileLayoutUpdatesXml(‘<?xml version=”…’, ‘Mage_Core_Model…’)
    #2 /home/books/public_html/app/code/core/Mage/Core/Model/Layout/Update.php(345): Mage_Core_Model_Layout_Update->fetchFileLayoutUpdates(‘frontend’, ‘default’, ‘hellominty’, ’1′)
    #3 /home/books/public_html/app/code/core/Mage/Core/Model/Layout/Update.php(246): Mage_Core_Model_Layout_Update->fetchPackageLayoutUpdates()
    #4 /home/books/public_html/app/code/core/Mage/Core/Model/Layout/Update.php(224): Mage_Core_Model_Layout_Update->merge(‘default’)
    #5 /home/books/public_html/app/code/core/Mage/Core/Controller/Varien/Action.php(305): Mage_Core_Model_Layout_Update->load(‘default’)
    #6 /home/books/public_html/app/code/core/Mage/Cms/Helper/Page.php(103): Mage_Core_Controller_Varien_Action->loadLayoutUpdates()
    #7 /home/books/public_html/app/code/core/Mage/Cms/Helper/Page.php(52): Mage_Cms_Helper_Page->_renderPage()
    #8 /home/books/public_html/app/code/core/Mage/Cms/controllers/IndexController.php(45): Mage_Cms_Helper_Page->renderPage(Object(Mage_Cms_IndexController), ‘home’)
    #9 /home/books/public_html/app/code/core/Mage/Core/Controller/Varien/Action.php(418): Mage_Cms_IndexController->indexAction(Object(Mage_Cms_IndexController), ‘home’)
    #10 /home/books/public_html/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(254): Mage_Core_Controller_Varien_Action->dispatch()
    #11 /home/books/public_html/app/code/core/Mage/Core/Controller/Varien/Front.php(177): Mage_Core_Controller_Varien_Router_Standard->match(‘index’)
    #12 /home/books/public_html/app/code/core/Mage/Core/Model/App.php(304): Mage_Core_Controller_Varien_Front->dispatch(Object(Mage_Core_Controller_Request_Http))
    #13 /home/books/public_html/app/Mage.php(596): Mage_Core_Model_App->run()
    #14 /home/books/public_html/index.php(78): Mage::run(Array)
    #15 {main}

    I replaced the catalogsearch.xml with an original one to get the site working again and now my quick search box is missing. Refreshing the cache doesn’t help. Help!

    UPDATE: The xml file had two closing block tags. I fixed that but the pager still doesn’t work and the quick search box is still missing.