Sharing is helping.

We offer you this space to share your knowledge about Magento and learn from our experienced customers.

    Home Forums Theme Forum HelloPodcast Breadcrumbs? Reply To: Breadcrumbs?



    Yeah, it sounds easy, but it’s not working. I have no idea why. Once I add that block to the page.xml file it kills the site. I try to reload a page on the front-end and the site just goes blank.

    I have created a file named “breadcrumbs-new.phtml” which is saved to /app/design/frontend/default/hellopodcast/template/page/html/breadcrumbs-new.phtml and it’s code is…



    Then, for testing purposed I’m using the 3columns.phtml layout. In that file I have edited the code for the “middle-container” to call on the “breadcrumbs-new” as shown in this file’s “middle-container” div of:

    <div class="middle-container">
    <div class="middle col-3-layout">
    <!-- start breadcrumbs-new -->
    <?php echo $this->getChildHtml('breadcrumbs-new') ?>
    <!-- end breadcrumbs-new -->
    <!-- start left -->
    <div class="col-left side-col">
    <?php echo $this->getChildHtml('left') ?> 
    <!-- end left -->
    <!-- start center -->
    <div id="main" class="col-main">
    <!-- start global messages -->
    <?php echo $this->getChildHtml('global_messages') ?>
    <!-- end global messages -->
    <!-- start content -->
    <?php echo $this->getChildHtml('content') ?> 
    <!-- end content -->
    <!-- end center -->
    <!-- start right -->
    <div class="col-right side-col">
    <?php echo $this->getChildHtml('right') ?> 
    <!-- end right -->

    After doing this, I can refresh the page on the front end and see in the source code that it is pulling up the newly added code, but just is blank for the content, sp it looks like this…

    <!– start breadcrumbs-new –>
    <!– end breadcrumbs-new –>

    …with no content inside it where I want to call int he breadcrumb links.

    Last step…in the page.xml file located in /app/design/frontend/default/hellopodcast/layout/page.xml just below the block for “breadcrumbs” I have duplicated that line of code and adjusted the name slightly, so now it looks like this…

    <block type="page/html_breadcrumbs" name="breadcrumbs" as="breadcrumbs">
    <block type="page/html_breadcrumbs-new" name="breadcrumbs-new" as="breadcrumbs-new">

    When the new page.xml file is uploaded to the server and I clear the cache through the admin, the front-end view of the site goes blank white. Once I remove that “breadcrumbs-new” block from page.xml, the site is back up. So, I’m stuck…do I need to make a change elsewhere as well, or edit something else within the page.xml file?

    Thanks, I really appreciate your support. I just want breadcrumbs on there, and I’ve spent at least 6 hours on this, it’s insane!!!